summary refs log tree commit diff
path: root/gnu/packages/javascript.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-26 21:02:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-27 21:04:37 +0100
commit94b779b6a4d0bbd0693e293d2f6f38afa6e8a6c3 (patch)
treee1f7eb1a16e419e863945841dd8407f8b4a76c6c /gnu/packages/javascript.scm
parent97156ba242a735abb444fdbac69515dc15a6bbf7 (diff)
downloadguix-94b779b6a4d0bbd0693e293d2f6f38afa6e8a6c3.tar.gz
gnu: mujs: Update to 1.0.2.
* gnu/packages/javascript.scm (mujs): Update to 1.0.2.
[source]: Download over HTTPS.
[home-page]: Update to redirected URL.
Diffstat (limited to 'gnu/packages/javascript.scm')
-rw-r--r--gnu/packages/javascript.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index 1fe62d2308..b52edb2254 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -371,16 +371,16 @@ means that these shams cause many ES5 methods to silently fail.")
 (define-public mujs
   (package
     (name "mujs")
-    (version "1.0.1")
+    (version "1.0.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "http://git.ghostscript.com/mujs.git")
+                    (url "https://git.ghostscript.com/mujs.git")
                     (commit version)))
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "0ch0s3vqs7agf65gbks32bj44nk1dr2s23ki47b0bhdhzvw9q93j"))))
+                "1angy1higk8bvh69frjhq1m6znhd75fzalaydz5rfzkdfyw52jgy"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
@@ -388,7 +388,7 @@ means that these shams cause many ES5 methods to silently fail.")
        #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out"))
                           (string-append "CC=gcc"))
        #:tests? #f)) ; no tests
-    (home-page "http://dev.mujs.com")
+    (home-page "https://artifex.com/mujs/")
     (synopsis "JavaScript interpreter written in C")
     (description "MuJS is a lightweight Javascript interpreter designed for
 embedding in other software to extend them with scripting capabilities.  MuJS