summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:08:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:53 +0300
commit3d12f59d1f8437f17914d2ae0cb6b46f3b2dedae (patch)
tree20bf0cf57a0fbe1c186f510dfbf3571f213bef7c /gnu/packages/julia-jll.scm
parente2ee6686efe11a439bb5c09a5d3543e78f4579f1 (diff)
downloadguix-3d12f59d1f8437f17914d2ae0cb6b46f3b2dedae.tar.gz
gnu: Add julia-expat-jll.
* gnu/packages/julia-jll.scm (julia-expat-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 651d15599b..c10d371769 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -133,6 +133,44 @@ originating @code{build_tarballs.jl} script can be found on the community
 build tree Yggdrasil.")
     (license license:expat)))
 
+(define-public julia-expat-jll
+  (package
+    (name "julia-expat-jll")
+    (version "2.2.10+0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Expat_jll.jl")
+               (commit (string-append "Expat-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0lkhkh0067lns35njpc1bqbx6653r99lrjcbgrihlln9a7k9qj1s"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("generate_wrapper_header.*")
+                    (string-append
+                      "generate_wrapper_header(\"Expat\", \""
+                      (assoc-ref inputs "expat") "\")\n"))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("expat" ,expat)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Expat_jll.jl")
+    (synopsis "Expat library wrappers")
+    (description "This package provides a wrapper for the expat library.")
+    (license license:expat)))
+
 (define-public julia-ffmpeg-jll
   (package
     (name "julia-ffmpeg-jll")