summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:15:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:51 +0300
commita18d0aac7ae02cff87aeda0ea0db24c854084910 (patch)
tree1a5af4a21dc0744d1ce918a4923dddc53ab380db /gnu/packages/julia-jll.scm
parent5cd1372745bb993654ca089cf0f75185de0eb2ec (diff)
downloadguix-a18d0aac7ae02cff87aeda0ea0db24c854084910.tar.gz
gnu: Add julia-openssl-jll.
* gnu/packages/julia-jll.scm (julia-openssl-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 40d1d2bfb6..acdfb926c7 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -671,6 +671,42 @@ originating @code{build_tarballs.jl} script can be found on the community
 build tree Yggdrasil.")
       (license license:expat))))
 
+(define-public julia-openssl-jll
+  (package
+    (name "julia-openssl-jll")
+    (version "1.1.1+2")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/OpenSSL_jll.jl")
+               (commit (string-append "OpenSSL-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0qly9pjhah95jdgvckkj615yfbsavvsygpfq9sqz4716q4zv0d5z"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("artifact\"OpenSSL\"")
+                    (string-append "\"" (assoc-ref inputs "openssl") "\""))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("openssl" ,openssl)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)))
+    (home-page "https://github.com/JuliaBinaryWrappers/OpenSSL_jll.jl")
+    (synopsis "Openssl library wrappers")
+    (description "This package provides a wrapper for the openssl library.")
+    (license license:expat)))
+
 (define-public julia-x264-jll
   (package
     (name "julia-x264-jll")