summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:36:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:55 +0300
commitd3903306e883fc263e4e726c36624a0c3340849a (patch)
tree272b9c423c165020ebcf13c619b6cd8bde74e22c /gnu/packages/julia-jll.scm
parentf7033423d3143373902461ef122a27a485432936 (diff)
downloadguix-d3903306e883fc263e4e726c36624a0c3340849a.tar.gz
gnu: Add julia-xorg-libxrandr-jll.
* gnu/packages/julia-jll.scm (julia-xorg-libxrandr-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 9708bd0175..80ace85e87 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1928,6 +1928,44 @@ build tree Yggdrasil.")
     (description "This package provides a wrapper for the libxinerama library.")
     (license license:expat)))
 
+(define-public julia-xorg-libxrandr-jll
+  (package
+    (name "julia-xorg-libxrandr-jll")
+    (version "1.5.2+3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Xorg_libXrandr_jll.jl")
+               (commit (string-append "Xorg_libXrandr-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0y4gsw5x643qdamf932agzdlyayzp63pn8j7j0lckd6dzqfdz46g"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("artifact\"Xorg_libXrandr\"")
+                    (string-append "\"" (assoc-ref inputs "libxrandr") "\""))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("libxrandr" ,libxrandr)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)
+       ("julia-xorg-libxext-jll" ,julia-xorg-libxext-jll)
+       ("julia-xorg-libxrender-jll" ,julia-xorg-libxrender-jll)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libXrandr_jll.jl")
+    (synopsis "Libxrandr library wrappers")
+    (description "This package provides a wrapper for the libxrandr library.")
+    (license license:expat)))
+
 (define-public julia-xorg-libxrender-jll
   (package
     (name "julia-xorg-libxrender-jll")