summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:45:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:56 +0300
commit47bcda6d143f862c6bc12ba71735581e854edcab (patch)
tree3fbe63a8a90410cb7c7529136e1e8aa09a8e4fb2 /gnu/packages/julia-jll.scm
parent4d6ef7eb2c8159e3ab8bf2e5d490960cd97958d0 (diff)
downloadguix-47bcda6d143f862c6bc12ba71735581e854edcab.tar.gz
gnu: Add julia-xorg-xcb-util-jll.
* gnu/packages/julia-jll.scm (julia-xorg-xcb-util-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 3ec9ae6269..6ce998707b 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -2200,6 +2200,43 @@ build tree Yggdrasil.")
     (description "This package provides a wrapper for the libXrender library.")
     (license license:expat)))
 
+(define-public julia-xorg-xcb-util-jll
+  (package
+    (name "julia-xorg-xcb-util-jll")
+    (version "0.4.0+1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Xorg_xcb_util_jll.jl")
+               (commit (string-append "Xorg_xcb_util-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0jywbxwf9x2naqsh9hh231bqpphh15v7cdhijcspjfggwkyq1npi"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("artifact\"Xorg_xcb_util\"")
+                    (string-append "\"" (assoc-ref inputs "xcb-util") "\""))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("xcb-util" ,xcb-util)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)
+       ("julia-xorg-libxcb-jll" ,julia-xorg-libxcb-jll)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Xorg_xcb_util_jll.jl")
+    (synopsis "Xcb-util library wrappers")
+    (description "This package provides a wrapper for the xcb-util library.")
+    (license license:expat)))
+
 (define-public julia-xorg-xkbcomp-jll
   (package
     (name "julia-xorg-xkbcomp-jll")