summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:59:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:52 +0300
commit5f7fb563095168280df0313c3ee5e8f941a35bc9 (patch)
tree896f215b41846e56a852f454d72ad2ac5eb5ad64 /gnu/packages/julia-jll.scm
parent088e1a50900f3aaa77c12c7ff5eb6e5f938b01c1 (diff)
downloadguix-5f7fb563095168280df0313c3ee5e8f941a35bc9.tar.gz
gnu: Add julia-libmount-jll.
* gnu/packages/julia-jll.scm (julia-libmount-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 637fd267dc..7c6316e683 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -36,6 +36,7 @@
   #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages julia)
   #:use-module (gnu packages libffi)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages mp3)
   #:use-module (gnu packages pcre)
@@ -647,6 +648,45 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
     (description "This package provides a wrapper for the libiconv library.")
     (license license:expat)))
 
+(define-public julia-libmount-jll
+  (package
+    (name "julia-libmount-jll")
+    (version "2.35.0+0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Libmount_jll.jl")
+               (commit (string-append "Libmount-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "04i4vm5rshz8nfmnxqx8rm3b9jd7b1xdiriac1bpsx3n0qf4pw89"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("generate_wrapper_header.*")
+                    (string-append
+                      "generate_wrapper_header(\"Libmount\", \""
+                      (assoc-ref inputs "util-linux") "\")\n"))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("util-linux" ,util-linux "lib")))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Libmount_jll.jl")
+    (synopsis "Libmount library wrappers")
+    (description "This package provides a wrapper for the libmount library
+from util-linux.")
+    (license license:expat)))
+
 (define-public julia-libpng-jll
   (package
     (name "julia-libpng-jll")