summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:25:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:54 +0300
commit7cb9173879aa814fd89e21d98035081f9f86e05b (patch)
tree062abfda4fba8eeeccceb9c69db3cae26de9501e /gnu/packages/julia-jll.scm
parent2b93e8cd66bf4f1e296528e62e866468a941f8ad (diff)
downloadguix-7cb9173879aa814fd89e21d98035081f9f86e05b.tar.gz
gnu: Add julia-xorg-libxext-jll.
* gnu/packages/julia-jll.scm (julia-xorg-libxext-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 33e7740298..7cf8899c94 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1612,6 +1612,43 @@ build tree Yggdrasil.")
     (description "This package provides a wrapper for the libxdmcp library.")
     (license license:expat)))
 
+(define-public julia-xorg-libxext-jll
+  (package
+    (name "julia-xorg-libxext-jll")
+    (version "1.3.4+2")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Xorg_libXext_jll.jl")
+               (commit (string-append "Xorg_libXext-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1xmx86l54apvqv0xwy0rha7knjl4x5crllqra56nhi0arhw8ywfc"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("artifact\"Xorg_libXext\"")
+                    (string-append "\"" (assoc-ref inputs "libxext") "\""))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("libxext" ,libxext)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)
+       ("julia-xorg-libx11-jll" ,julia-xorg-libx11-jll)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libXext_jll.jl")
+    (synopsis "LibXext library wrappers")
+    (description "This package provides a wrapper for the libxext library.")
+    (license license:expat)))
+
 (define-public julia-xorg-xtrans-jll
   (package
     (name "julia-xorg-xtrans-jll")