summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:25:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:51 +0300
commitb3ffbab8f84056fe714b53885811bcfc1711c579 (patch)
tree9f6899b22d0a6de6d74a0edfcf5e2e22824152f6 /gnu/packages/julia-jll.scm
parent0c1b3444e1924c0998820f83ed6f4bea23eb36c7 (diff)
downloadguix-b3ffbab8f84056fe714b53885811bcfc1711c579.tar.gz
gnu: Add julia-libiconv-jll.
* gnu/packages/julia-jll.scm (julia-libiconv-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 6d0549207f..2b2ed8a87b 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -26,6 +26,7 @@
   #:use-module (guix build-system julia)
   #:use-module (gnu packages)
   #:use-module (gnu packages audio)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages fribidi)
@@ -526,6 +527,44 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
     (description "This package provides a wrapper for the libfdk audio library.")
     (license license:expat)))
 
+(define-public julia-libiconv-jll
+  (package
+    (name "julia-libiconv-jll")
+    (version "1.16.1+0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Libiconv_jll.jl")
+               (commit (string-append "Libiconv-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "185f2460ypig1klgi8rdb0s2c8l4hxdbmsz9ihj7bdydl964s2hh"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("generate_wrapper_header.*")
+                    (string-append
+                      "generate_wrapper_header(\"Libiconv\", \""
+                      (assoc-ref inputs "libiconv") "\")\n"))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("libiconv" ,libiconv)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Libiconv_jll.jl")
+    (synopsis "Libiconv library wrappers")
+    (description "This package provides a wrapper for the libiconv library.")
+    (license license:expat)))
+
 (define-public julia-libpng-jll
   (package
     (name "julia-libpng-jll")