summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:41:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:56 +0300
commitd6227a3939821ade5192069e5b981ae61ee8de3f (patch)
tree256401dbe296ba979847d7348a10c86f490dba37 /gnu/packages/julia-jll.scm
parenta2eb232b6ab7525af8d83964fd819b14b0a332ef (diff)
downloadguix-d6227a3939821ade5192069e5b981ae61ee8de3f.tar.gz
gnu: Add julia-xorg-xkbcomp-jll.
* gnu/packages/julia-jll.scm (julia-xorg-xkbcomp-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 25a78e8074..0e32b46f8b 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -2160,6 +2160,43 @@ build tree Yggdrasil.")
     (description "This package provides a wrapper for the libXrender library.")
     (license license:expat)))
 
+(define-public julia-xorg-xkbcomp-jll
+  (package
+    (name "julia-xorg-xkbcomp-jll")
+    (version "1.4.2+3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Xorg_xkbcomp_jll.jl")
+               (commit (string-append "Xorg_xkbcomp-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1rkb9525iq0jjpq8v333b728kfillgixxsim37mqdplad85l36wl"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("artifact\"Xorg_xkbcomp\"")
+                    (string-append "\"" (assoc-ref inputs "xkbcomp") "\""))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("xkbcomp" ,xkbcomp)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)
+       ("julia-xorg-libxkbfile-jll" ,julia-xorg-libxkbfile-jll)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Xorg_xkbcomp_jll.jl")
+    (synopsis "xkbcomp library wrappers")
+    (description "This package provides a wrapper for the xkbcomp library.")
+    (license license:expat)))
+
 (define-public julia-xorg-xtrans-jll
   (package
     (name "julia-xorg-xtrans-jll")