summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-23 21:45:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-23 21:45:21 -0400
commit839bb4616f13171a23ad7937bf57d0a01d61d42a (patch)
tree01de78a5ce973b9fb7ac0f9216d64f736f8e163d /gnu/packages/julia-jll.scm
parent0357bbbcd850f9220078a62da3c30358b8983765 (diff)
parentef71e3290916583973724316e815cee840c1b6d8 (diff)
downloadguix-839bb4616f13171a23ad7937bf57d0a01d61d42a.tar.gz
Merge remote-tracking branch 'origin/master' into staging.
With resolved conflicts in:
	gnu/packages/ibus.scm
	gnu/packages/image.scm
	gnu/packages/lisp.scm
	gnu/packages/virtualization.scm
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm74
1 files changed, 74 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 1aab2f78ce..2320b03595 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -232,6 +232,42 @@ originating @code{build_tarballs.jl} script can be found on the community
 build tree Yggdrasil.")
     (license license:expat)))
 
+(define-public julia-erfa-jll
+  (package
+    (name "julia-erfa-jll")
+    (version "2.0.0+0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaBinaryWrappers/ERFA_jll.jl")
+             (commit (string-append "ERFA-v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0knlck3vqr19g9z8zgjr7lj0qf1lisji5s2lm00y3ymv9bkj59sl"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f ;no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'link-depot 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map (lambda (wrapper)
+                    (substitute* wrapper
+                      (("generate_wrapper_header.*")
+                       (string-append
+                        "generate_wrapper_header(\"ERFA\", \""
+                        (assoc-ref inputs "erfa") "\")\n"))))
+                  ;; There's a Julia file for each platform, override them all
+                  (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs (list erfa))
+    (propagated-inputs (list julia-jllwrappers))
+    (home-page "https://github.com/JuliaBinaryWrappers/ERFA_jll.jl")
+    (synopsis "ERFA library wrappers")
+    (description "This package provides a wrapper for the erfa library.")
+    (license license:expat)))
+
 (define-public julia-expat-jll
   (package
     (name "julia-expat-jll")
@@ -1727,6 +1763,44 @@ build tree Yggdrasil.")
     (description "This package provides a wrapper for the wayland-protocols library.")
     (license license:expat)))
 
+(define-public julia-wcs-jll
+  (package
+    (name "julia-wcs-jll")
+    (version "7.7.0+0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaBinaryWrappers/WCS_jll.jl")
+             (commit (string-append "WCS-v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "16i9899jwcp5i9mh88rn4b83v3i5v8g1jygixrr0grjnvf5qfvpk"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'link-depot 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+              (lambda (wrapper)
+                (substitute* wrapper
+                  (("generate_wrapper_header.*")
+                   (string-append
+                    "generate_wrapper_header(\"WCS\", \""
+                    (assoc-ref inputs "wcslib") "\")\n"))))
+              ;; There's a Julia file for each platform, override them all
+              (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     (list wcslib))
+    (propagated-inputs
+     (list julia-jllwrappers))
+    (home-page "https://github.com/JuliaBinaryWrappers/WCS_jll.jl")
+    (synopsis "WCS library wrappers")
+    (description "This package provides a wrapper for the wcs library.")
+    (license license:expat)))
+
 (define-public julia-x264-jll
   (package
     (name "julia-x264-jll")