summary refs log tree commit diff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:06:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:52 +0300
commita4dbdbaccfd5eda4ef0992b5f8ed4cae8f575cef (patch)
tree25cdc081c7e9c6928c11ad714d309643562effff /gnu/packages/julia-jll.scm
parentb729895ae2f9e0d5e30b35310a49fd92813b8a6e (diff)
downloadguix-a4dbdbaccfd5eda4ef0992b5f8ed4cae8f575cef.tar.gz
gnu: Add julia-pixman-jll.
* gnu/packages/julia-jll.scm (julia-pixman-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 203bc9cef7..2210778065 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -44,6 +44,7 @@
   #:use-module (gnu packages tls)
   #:use-module (gnu packages video)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages xml))
 
@@ -1076,6 +1077,44 @@ build tree Yggdrasil.")
     (description "This package provides a wrapper for the pcre library.")
     (license license:expat)))
 
+(define-public julia-pixman-jll
+  (package
+    (name "julia-pixman-jll")
+    (version "0.40.1+0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Pixman_jll.jl")
+               (commit (string-append "Pixman-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0ahawpgsiccmpa7gyxny7hq058igqvpza7ybqa44vl2nynnry2g7"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("generate_wrapper_header.*")
+                    (string-append
+                      "generate_wrapper_header(\"Pixman\", \""
+                      (assoc-ref inputs "pixman") "\")\n"))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("pixman" ,pixman)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Pixman_jll.jl")
+    (synopsis "Pixman library wrappers")
+    (description "This package provides a wrapper for the pixman library.")
+    (license license:expat)))
+
 (define-public julia-x264-jll
   (package
     (name "julia-x264-jll")