summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-19 00:04:44 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-03 12:30:24 +0100
commite21c19b2ad62b3afc87fa85de85c7b649673d9f4 (patch)
tree05d4a6d037ea9de6108483d3c3285cbec63dc5b4 /gnu/packages/julia-xyz.scm
parent58f20fa8181bdcd4269671e1d3cef1268947af3a (diff)
downloadguix-e21c19b2ad62b3afc87fa85de85c7b649673d9f4.tar.gz
gnu: Add julia-leapseconds.
* gnu/packages/julia-xyz.scm (julia-leapseconds): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index f6de56e858..0979f21664 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3576,6 +3576,31 @@ equations in string literals in the Julia language.")
 implementation of matrix-free methods for iterative solvers.")
     (license license:expat)))
 
+(define-public julia-leapseconds
+  (package
+    (name "julia-leapseconds")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaTime/LeapSeconds.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "13xa49dx11n7ii77rw6300h1rfl4qlq05ypsprvfmvyww81angkp"))))
+    (build-system julia-build-system)
+    (native-inputs
+     (list julia-erfa))
+    (home-page "https://github.com/JuliaTime/LeapSeconds.jl")
+    (synopsis "Leap seconds in Julia")
+    (description
+     "@code{LeapSeconds} provides a functionality to return the difference
+between @acronym{TAI, International Atomic Time} and @acronym{UTC, Coordinated
+Universal Time} or vice versa for a given date.  For dates after 1972-01-01, this
+is the number of leap seconds.")
+    (license license:expat)))
+
 (define-public julia-linesearches
   (package
     (name "julia-linesearches")