summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-01-19 12:08:27 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-20 22:29:15 +0100
commit52d09b1f14ad98d1c1e611173acf7fc04bd653b7 (patch)
tree6e9eecde9c9451de177550ea80f1702d8757bc74 /gnu/packages/julia-xyz.scm
parentfc781578588436a68ad0e5afd9dad994c60e6a49 (diff)
downloadguix-52d09b1f14ad98d1c1e611173acf7fc04bd653b7.tar.gz
gnu: Add julia-bufferedstreams.
* gnu/packages/julia-xyz.scm (julia-bufferedstreams): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 738060f865..a3c5c55a86 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -67,6 +67,34 @@ code easy by supplying a framework for writing and running groups of
 benchmarks as well as comparing benchmark results.")
     (license license:expat)))
 
+(define-public julia-bufferedstreams
+  (package
+    (name "julia-bufferedstreams")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/BioJulia/BufferedStreams.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0sf4sxbq55mg2pwxyxf0c839z1lk0yxg8nmb7617bfbvw31cp88z"))))
+    (build-system julia-build-system)
+    ;; The package is old and tests are using undefined functions.  They also
+    ;; freeze, see
+    ;; https://travis-ci.org/BioJulia/BufferedStreams.jl/jobs/491050182
+    (arguments
+     '(#:tests? #f
+       #:julia-package-name "BufferedStreams"))
+    (propagated-inputs `(("julia-compat" ,julia-compat)))
+    (home-page "https://github.com/BioJulia/BufferedStreams.jl")
+    (synopsis "Fast composable IO streams")
+    (description "@code{BufferedStreams.jl} provides buffering for IO
+operations.  It can wrap any @code{IO} type automatically making incremental
+reading and writing faster.")
+    (license license:expat)))
+
 (define-public julia-compat
   (package
     (name "julia-compat")