summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-19 00:04:47 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-03 12:30:40 +0100
commitb7804b473fe56c69823e5bfa842691f24559d7d2 (patch)
tree0daad6af79d353a64038b1339b6b045d3d0b7d81 /gnu/packages/julia-xyz.scm
parenta0ca88b1a6e1e820fc0513acf37b2e495e36baca (diff)
downloadguix-b7804b473fe56c69823e5bfa842691f24559d7d2.tar.gz
gnu: Add julia-earthorientation.
* gnu/packages/julia-xyz.scm (julia-earthorientation): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index ffbdb2a1a7..096c094da4 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1829,6 +1829,31 @@ them.  Conversions and promotions are defined to allow performing operations on
 combinations of dual numbers with predefined Julia numeric types.")
     (license license:expat)))
 
+(define-public julia-earthorientation
+  (package
+    (name "julia-earthorientation")
+    (version "0.7.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaAstro/EarthOrientation.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1fschx4qmfd83q0ymgbzqi1dl0drbh45cd7hlcbqnm9lfmw2d847"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     (list julia-leapseconds
+           julia-optionaldata
+           julia-remotefiles))
+    (home-page "https://github.com/JuliaAstro/EarthOrientation.jl")
+    (synopsis "Calculate Earth orientation parameters from IERS tables in Julia")
+    (description
+     "This package provides a functionality to calculate Earth orientation parameters
+with data retrieved from @acronym{IERS, International Earth Rotation Service}.")
+    (license license:expat)))
+
 (define-public julia-ellipsisnotation
   (package
     (name "julia-ellipsisnotation")