summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:43:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:54:48 +0300
commit4541cda7d76b8fdea39b2abfda283e1e392d12fd (patch)
treeb92c7394f2ca3cfb12ad589e707ec3202b2fb151 /gnu/packages/julia-xyz.scm
parenta33695945c9d762b0a5568cbfb18274736d36186 (diff)
downloadguix-4541cda7d76b8fdea39b2abfda283e1e392d12fd.tar.gz
gnu: Add julia-indirectarrays.
* gnu/packages/julia-xyz.scm (julia-indirectarrays): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 71f2019ec8..82e7be95ab 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1025,6 +1025,33 @@ out of dictionaries, tuples, etc, extending this ability beyond
 @code{AbstractArray}.")
     (license license:expat)))
 
+(define-public julia-indirectarrays
+  (package
+    (name "julia-indirectarrays")
+    (version "0.5.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaArrays/IndirectArrays.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0l0jq0jnr9z3k431ni82xycq7mqapgxrbrx4yyk6lycvi41ipm4s"))))
+    (build-system julia-build-system)
+    (native-inputs
+     `(("julia-colors" ,julia-colors)
+       ("julia-fixedpointnumbers" ,julia-fixedpointnumbers)
+       ("julia-mappedarrays" ,julia-mappedarrays)))
+    (home-page "https://github.com/JuliaArrays/IndirectArrays.jl")
+    (synopsis "Julia implementation of indexed arrays")
+    (description "An @code{IndirectArray} is one that encodes data using a
+combination of an @code{index} and a @code{value} table.  Each element is
+assigned its own index, which is used to retrieve the value from the
+@code{value} table.  Among other uses, @code{IndirectArrays} can represent
+indexed images, sometimes called \"colormap images\" or \"paletted images.\"")
+    (license license:expat)))
+
 (define-public julia-inifile
   (package
     (name "julia-inifile")