summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-27 15:52:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-27 16:53:01 +0300
commit114db2b9c40181f6c4c0f7121197b26060b50909 (patch)
treeaa960173936bf461b4eac67283c86de385d6c26b /gnu/packages/julia-xyz.scm
parent34ab622dc355e425ae45414cc36cff93ccd5717a (diff)
downloadguix-114db2b9c40181f6c4c0f7121197b26060b50909.tar.gz
gnu: Add julia-invertedindices.
* gnu/packages/julia-xyz.scm (julia-invertedindices): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 448197ca06..c18be17be7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -919,6 +919,29 @@ conditional ifelse.  It is similar to @code{Core.ifelse} but it is extendable.")
 interfaces with @file{.ini} files.")
     (license license:expat)))
 
+(define-public julia-invertedindices
+  (package
+    (name "julia-invertedindices")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/mbauman/InvertedIndices.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1179z20yxnkyziip7gn26wr1g3k3ssl1ci7pig3khc900f62di46"))))
+    (build-system julia-build-system)
+    (native-inputs
+     `(("julia-offsetarrays" ,julia-offsetarrays)))
+    (home-page "https://github.com/mbauman/InvertedIndices.jl")
+    (synopsis "Index type that allows for inverted selections")
+    (description "This package just exports one type: the @code{InvertedIndex},
+or @code{Not} for short.  It can wrap any supported index type and may be used
+as an index into any @code{AbstractArray} subtype, including OffsetArrays.")
+    (license license:expat)))
+
 (define-public julia-iocapture
   (package
     (name "julia-iocapture")