summary refs log tree commit diff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-18 16:18:08 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-18 16:51:13 +0100
commitcd1cbb61076630fe065115426cad3ecde455b53d (patch)
treeec06a661b1252653a3eab0c197437d858dfe25c7 /gnu/packages/julia.scm
parent674dbeb43639db31c3f3a6e69ee7203296d0b50f (diff)
downloadguix-cd1cbb61076630fe065115426cad3ecde455b53d.tar.gz
gnu: libuv-julia: Move next to libuv.
Inheritance should happen within the same module.

* gnu/packages/julia.scm (libuv-julia): Move to...
* gnu/packages/libevent.scm (libuv-julia): ... here.
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index e621c8b936..a2ae789dca 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -54,26 +54,6 @@
   #:use-module (gnu packages wget)
   #:use-module (ice-9 match))
 
-(define libuv-julia
-  (let ((commit "fb3e3364c33ae48c827f6b103e05c3f0e78b79a9")
-        (revision "3"))
-    ;; When upgrading Julia, also upgrade this.  Get the commit from
-    ;; https://github.com/JuliaLang/julia/blob/v1.6.1/deps/libuv.version
-    (package
-      (inherit libuv)
-      (name "libuv-julia")
-      (version (git-version "2.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/JuliaLang/libuv")
-                       (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1kqpn19d20aka30h6q5h8lnzyp0vw0xzgx0wm4w2r5j6yf76m2hr"))))
-      (home-page "https://github.com/JuliaLang/libuv"))))
-
 (define libunwind-julia
   ;; The Julia projects requires their patched version.
   ;; Get from https://github.com/JuliaLang/julia/tree/master/deps/patches