summary refs log tree commit diff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-26 23:43:36 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:08 +0100
commit8b60547c2306b0bddfe904bb7a6d96cc8695a7d9 (patch)
treebd8500b7bf81fac948543825bc2878848cac0508 /gnu/packages/kde-frameworks.scm
parent98fd85c0320f849ad174e4e45c5c86dd81cfcbd2 (diff)
downloadguix-8b60547c2306b0bddfe904bb7a6d96cc8695a7d9.tar.gz
gnu: bluez-qt: Add qtdeclarative-5 to inputs.
* gnu/packages/kde-frameworks.scm (qtdeclarative-5)[inputs]: Add
qtdeclarative-5.
[arguments]: Disable failing test.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ee4ba95263..3632b61334 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -345,21 +345,19 @@ http://freedesktop.org/wiki/Specifications/open-collaboration-services/")
     (native-inputs
      (list dbus extra-cmake-modules))
     (inputs
-     ;; TODO: qtdeclarative-5 (yields one failing test)
-     (list qtbase-5))
+     (list qtdeclarative-5
+           qtbase-5))
     (arguments
      (list #:configure-flags
            #~(list (string-append
                     "-DUDEV_RULES_INSTALL_DIR=" #$output "/lib/udev/rules.d"))
-           ;; TODO: Make tests pass: DBUS_FATAL_WARNINGS=0 still yields 7/8 tests
-           ;; failing.  When running after install, tests hang.
-           #:phases
-            '(modify-phases %standard-phases
-              (replace 'check
-                (lambda* (#:key tests? #:allow-other-keys)
-                  (when tests?
-                    (setenv "DBUS_FATAL_WARNINGS" "0")
-                    (invoke "dbus-launch" "ctest")))))))
+	#:phases
+        #~(modify-phases %standard-phases
+            (replace 'check
+              (lambda* (#:key tests? #:allow-other-keys)
+                (when tests?
+                  (setenv "DBUS_FATAL_WARNINGS" "0")
+                  (invoke "dbus-launch" "ctest" "-E" "bluezqt-qmltests")))))))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "QML wrapper for BlueZ")
     (description "bluez-qt is a Qt-style library for accessing the bluez