summary refs log tree commit diff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-23 13:13:02 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-04 10:10:40 +0100
commitdaff96de1fc9b2316fd4a62ac5f7173ea448afa5 (patch)
tree7b365a27c77db9d143cfad57f9c09150024268d2 /gnu/packages/kde-frameworks.scm
parentbe8cb44a9c4af541fc3ba6cafb1228fcf03686d0 (diff)
downloadguix-daff96de1fc9b2316fd4a62ac5f7173ea448afa5.tar.gz
gnu: kconfigwidgets: Make QDirIterator follow symlinks.
Transfer the NixOS patch "qdiriterator-follow-symlinks" for kconfigwidgets as
of 2018-02-17.

* gnu/packages/kde-frameworks.scm(kconfigwidgets)<patch>: New phase.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index e8e2097513..458437cb0e 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2152,6 +2152,13 @@ KCModules can be created with the KConfigWidgets framework.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch
+           (lambda _
+             (substitute* "src/khelpclient.cpp"
+               ;; make QDirIterator follow symlinks
+               (("^\\s*(QDirIterator it\\(.*, QDirIterator::Subdirectories)(\\);)" _ a b)
+                (string-append a " | QDirIterator::FollowSymlinks" b)))
+             #t))
          (add-before 'check 'check-setup
            (lambda _
              ;; make Qt render "offscreen", required for tests