summary refs log tree commit diff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-27 22:19:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-28 00:33:47 +0100
commitff3375251d6a316e3ee05589d70a8bb135ec47a6 (patch)
tree3bb25cc788c63f336687451a3337f681cc669bd3 /gnu/packages/kde-frameworks.scm
parentdcc7fad0016d7ef062ccfe0b1deb3368251e8ff8 (diff)
downloadguix-ff3375251d6a316e3ee05589d70a8bb135ec47a6.tar.gz
gnu: Use the test-only Xorg variant for tests.
* gnu/packages/education.scm (gcompris-qt)[native-inputs]: Change XORG-SERVER
to XORG-SERVER-FOR-TESTS.
* gnu/packages/engineering.scm (pcb, qucs, openscad)[native-inputs]: Likewise.
* gnu/packages/gnome.scm (libbonoboui, d-feet, gspell, libdazzle, libhandy)[native-inputs]: Likewise.
* gnu/packages/gnupg.scm (parcimonie)[native-inputs]: Likewise.
* gnu/packages/graphics.scm (opensubdiv, rapicorn)[native-inputs]: Likewise.
* gnu/packages/gtk.scm (gtksourceview-2, gtksourceview)[native-inputs]: Likewise.
* gnu/packages/image-processing.scm (opencv)[native-inputs]: Likewise.
* gnu/packages/kde-frameworks.scm (kconfig, kcoreaddons, kwidgetsaddons,
kwindowsystem, kdeclarative)[native-inputs]: Likewise.
* gnu/packages/kde-plasma.scm (kscreenlocker)[native-inputs]: Likewise.
* gnu/packages/messaging.scm (gajim)[native-inputs]: Likewise.
* gnu/packages/python-xyz.scm (python-seaborn)[native-inputs]: Likewise.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ec735d8903..6f7c5df7b4 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -483,7 +483,7 @@ Internet).")
        ("extra-cmake-modules" ,extra-cmake-modules)
        ("inetutils" ,inetutils)
        ("qttools" ,qttools)
-       ("xorg-server" ,xorg-server)))
+       ("xorg-server" ,xorg-server-for-tests)))
     (inputs
      `(("qtbase" ,qtbase)))
     (arguments
@@ -548,7 +548,7 @@ propagate their changes to their respective configuration files.")
        ("qttools" ,qttools)
        ("shared-mime-info" ,shared-mime-info)
        ;; TODO: FAM: File alteration notification http://oss.sgi.com/projects/fam
-       ("xorg-server" ,xorg-server))) ; for the tests
+       ("xorg-server" ,xorg-server-for-tests))) ; for the tests
     (inputs
      `(("qtbase" ,qtbase)))
     (arguments
@@ -1041,7 +1041,7 @@ represented by a QPoint or a QSize.")
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("qttools" ,qttools)
-       ("xorg-server" ,xorg-server)))
+       ("xorg-server" ,xorg-server-for-tests)))
     (inputs
      `(("qtbase" ,qtbase)))
     (arguments
@@ -1091,7 +1091,7 @@ configuration pages, message boxes, and password requests.")
        ("dbus" ,dbus) ; for the tests
        ("openbox" ,openbox) ; for the tests
        ("qttools" ,qttools)
-       ("xorg-server" ,xorg-server))) ; for the tests
+       ("xorg-server" ,xorg-server-for-tests))) ; for the tests
     (inputs
      `(("libxrender" ,libxrender)
        ("qtbase" ,qtbase)
@@ -2201,7 +2201,7 @@ their settings.")
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)
-       ("xorg-server" ,xorg-server)))
+       ("xorg-server" ,xorg-server-for-tests)))
     (inputs
      `(("kauth" ,kauth)
        ("kbookmarks" ,kbookmarks)