summary refs log tree commit diff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-19 20:06:18 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-13 13:53:45 +0200
commitfa10ae4fbb7c1c12e6de22a6a97a322f09df2a86 (patch)
tree9822f9d53ea74a44ecfc9fc29ceaaa26451e2b15 /gnu/packages/kde-frameworks.scm
parent66e7e43450ddcfb173cc8609fca5d8bcf21f6c25 (diff)
downloadguix-fa10ae4fbb7c1c12e6de22a6a97a322f09df2a86.tar.gz
gnu: kfilemetadata: Enable support for PDF files and audio files.
- Qt5 Multimedia module is needed to bild an extractor for audio files.
- poppler, which was defined as input, is not including the requested Qt
  support, thus poppler-qt is needed.

* gnu/packages/kde-frameworks.scm (kfilemetadata)[inuts]: Add qtmultimedia,
  replace poppler by poppler-qt5. [native-inputs]: Add pkg-config.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 40bc94a12e..f9c4ff8dcb 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1505,18 +1505,21 @@ from DocBook files.")
              #t)))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("pkg-config" ,pkg-config)
        ("python-2" ,python-2)))
     (inputs
      `(("attr" ,attr)
+       ;; TODO: EPub http://sourceforge.net/projects/ebook-tools
        ("karchive" ,karchive)
        ("ki18n" ,ki18n)
+       ("qtmultimedia" ,qtmultimedia)
        ("qtbase" ,qtbase)
        ;; Required run-time packages
        ("catdoc" ,catdoc)
        ;; Optional run-time packages
        ("exiv2" ,exiv2)
        ("ffmpeg" ,ffmpeg)
-       ("poppler" ,poppler)
+       ("poppler-qt5" ,poppler-qt5)
        ("taglib" ,taglib)))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Extract metadata from different fileformats")