summary refs log tree commit diff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-05 23:38:25 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:28 +0100
commit789cf5c397edc24b6a1468615852708abe5bd117 (patch)
tree189f3705ef17f668a67ce449499676d4e82ee474 /gnu/packages/kde-pim.scm
parent29157edcd669e6cb500deee9e41a655a0da17618 (diff)
downloadguix-789cf5c397edc24b6a1468615852708abe5bd117.tar.gz
gnu: Add kontactinterface.
* gnu/packages/kde-pim.scm (kontactinterface): New variable.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 2ced957708..3d11ec7870 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -521,6 +521,33 @@ easier to do so.")
     (description "A library for MIME handling.")
     (license license:lgpl2.0+)))
 
+(define-public kontactinterface
+  (package
+    (name "kontactinterface")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/kontactinterface-" version ".tar.xz"))
+       (sha256
+        (base32 "1p0iw9i8cxh3jn7094wvxhlpc2sw52q8csfdgch1lf3dwhkpp0k7"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("kcoreaddons" ,kcoreaddons)
+       ("ki18n" ,ki18n)
+       ("kiconthemes" ,kiconthemes)
+       ("kparts" ,kparts)
+       ("kwindowsystem" ,kwindowsystem)
+       ("kxmlgui" ,kxmlgui)
+       ("qtbase" ,qtbase)))
+    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (synopsis "Kontact interface library")
+    (description "Kontact Interface library.")
+    (license license:lgpl2.0+)))
+
 (define-public kpimtextedit
   (package
     (name "kpimtextedit")