summary refs log tree commit diff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-02 15:34:14 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-19 11:36:21 +0100
commitd9491d5053ea856fe4fadc84d73d6979e9463a96 (patch)
tree5cc7a9ad33e9cd22d4f7d579eb855eeb897f0b23 /gnu/packages/kde-pim.scm
parent9d95d8bd120072cb3b983da86baa645c5b2ecd89 (diff)
downloadguix-d9491d5053ea856fe4fadc84d73d6979e9463a96.tar.gz
gnu: Add kcalendarsupport.
* gnu/packages/kde-pim.scm (kcalendarsupport): New variable.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index a9ceac591f..27ec2825ae 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -467,6 +467,52 @@ modern blogging web application that provides an XML data interface supports
 one of the APIs mentioned above.")
     (license license:lgpl2.0+)))
 
+(define-public kcalendarsupport
+  (package
+    (name "kcalendarsupport")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/calendarsupport-" version ".tar.xz"))
+       (sha256
+        (base32 "1hwfh5njq4614ypwdilna33hdcn11kshpwg6n27cag1qhwrxs1i4"))))
+    (properties `((upstream-name . "calendarsupport")))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("akonadi" ,akonadi)
+       ("akonadi-calendar" ,akonadi-calendar)
+       ("akonadi-mime" ,akonadi-mime)
+       ("boost" ,boost)
+       ("kcalendarcore" ,kcalendarcore)
+       ("kcalutils", kcalutils)
+       ("kcompletion" ,kcompletion)
+       ("kdbusaddons" ,kdbusaddons)
+       ("kdepim-apps-libs" ,kdepim-apps-libs)
+       ("kguiaddons" ,kguiaddons)
+       ("kholidays" ,kholidays)
+       ("ki18n" ,ki18n)
+       ("kiconthemes" ,kiconthemes)
+       ("kidentitymanagement" ,kidentitymanagement)
+       ("kio" ,kio)
+       ("kitemmodels" ,kitemmodels)
+       ("kmime" ,kmime)
+       ("kpimcommon" ,kpimcommon)
+       ("kpimtextedit" ,kpimtextedit)
+       ("ktextwidgets" ,ktextwidgets)
+       ("kxmlgui" ,kxmlgui)
+       ("qtbase" ,qtbase)))
+    (home-page "https://api.kde.org/stable/calendarsupport/")
+    (synopsis "Calendar Support library for KDE PIM")
+    (description "The Calendar Support library provides helper utilities for
+calendaring applications.")
+    (license ;; GPL for programs, LGPL for libraries
+     (list license:gpl2+ license:lgpl2.0+))))
+
 (define-public kcalutils
   (package
     (name "kcalutils")