summary refs log tree commit diff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-27 17:01:13 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:08 +0100
commit448df3cde19e648c8ac65472b10bc8011e5d4151 (patch)
tree77aaedeb6f3df08c93f8e8f05f36a1db38599f3b /gnu/packages/kde-plasma.scm
parentfb94d0a17d83d5f11a7c956d606018a23d504f84 (diff)
downloadguix-448df3cde19e648c8ac65472b10bc8011e5d4151.tar.gz
gnu: Add ksysguard.
* gnu/packages/kde-plasma.scm (ksysguard): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 31b143ab4e..14733c7c0a 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -253,6 +253,43 @@ call it if it is not associated to a terminal.")
      "@code{kscreenlocker} is a library for creating secure lock screens.")
     (license license:gpl2+)))
 
+(define-public ksysguard
+  (package
+    (name "ksysguard")
+    (version "5.22.0")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://kde/stable/ksysguard/" version
+                          "/ksysguard-" version ".tar.xz"))
+      (sha256
+       (base32 "0bb2aj46v7ig0wn3ir68igryl2gblz2n75cddn8fwamvbx76570g"))))
+    (build-system qt-build-system)
+    ;; TODO: No tests found
+    (native-inputs
+     (list extra-cmake-modules kdoctools))
+    (inputs
+     (list kconfig
+       kcoreaddons
+       kdbusaddons
+       ki18n
+       kiconthemes
+       kinit
+       kio
+       kitemviews
+       knewstuff
+       knotifications
+       kwindowsystem
+       libksysguard
+       `(,lm-sensors "lib")
+       qtbase-5))
+    (home-page "https://www.kde.org/applications/system/ksysguard/")
+    (synopsis "Plasma process and performance monitor")
+    (description "KSysGuard is a program to monitor various elements of your
+system, or any other remote system with the KSysGuard daemon (ksysgardd)
+installed.")
+    (license license:gpl2+)))
+
 (define-public libkscreen
   (package
     (name "libkscreen")