summary refs log tree commit diff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-10-04 15:09:20 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:16 +0100
commit7d9cd434777bc341ae098e057a209d9ae90677a2 (patch)
treed39c23b28400c021708bbe5cb8db2bb0d49d0d0f /gnu/packages/kde-plasma.scm
parent1b1bbe3eb08a417766b9835d60f0a4207f3c977d (diff)
downloadguix-7d9cd434777bc341ae098e057a209d9ae90677a2.tar.gz
gnu: Add plasma-bigscreen.
* gnu/packages/kde-plasma.scm (plasma-bigscreen): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 0771abe67a..ebed48234d 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1431,6 +1431,52 @@ on top of Baloo.")
      "KDE Plasma is an advanced graphical desktop system.")
     (license license:gpl2+)))
 
+(define-public plasma-bigscreen
+  (package
+    (name "plasma-bigscreen")
+    (version "5.25.90")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/unstable/plasma/" version
+                                  "/" name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1445j8hzfvh2z91fa8nxrc0z576c67cq5fxcs19pmzpnjjli1ads"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'fix-startplasma
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (substitute* "bin/plasma-bigscreen-wayland.in"
+                              (("^startplasma-wayland")
+                               (search-input-file inputs
+                                                  "/bin/startplasma-wayland")))
+                              (substitute* "bin/plasma-bigscreen-x11"
+                                (("startplasma-x11")
+                                 (search-input-file inputs
+                                                    "/bin/startplasma-x11"))))))))
+    (native-inputs (list extra-cmake-modules))
+    (inputs (list kactivities
+                  kactivities-stats
+                  plasma-framework
+                  ki18n
+                  kirigami
+                  kdeclarative
+                  kcmutils
+                  knotifications
+                  kio
+                  kwayland
+                  kwindowsystem
+                  plasma-workspace
+                  qtbase-5
+                  qtmultimedia-5))
+    (home-page "https://invent.kde.org/plasma/plasma-bigscreen")
+    (synopsis "Plasma shell for TVs")
+    (description
+     "This package provides a big launcher designed for large screens.  It
+is controllable via voice or TV remote.")
+    (license license:gpl2+)))
+
 (define-public plasmatube
   (package
     (name "plasmatube")