summary refs log tree commit diff
path: root/gnu/packages/kde-systemtools.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2023-08-10 21:26:28 +0200
committer宋文武 <iyzsong@member.fsf.org>2023-08-11 18:27:40 +0800
commitb01f6490ba963253164ca8b35a1b12f52972b2aa (patch)
treec8e84f82df047104b2b79ff53761571dde5bdefb /gnu/packages/kde-systemtools.scm
parent79c37f9fa8d06bdfbdf49eea61715db0b1a4137c (diff)
downloadguix-b01f6490ba963253164ca8b35a1b12f52972b2aa.tar.gz
gnu: Add spectacle.
* gnu/packages/kde-systemtools.scm (spectacle): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde-systemtools.scm')
-rw-r--r--gnu/packages/kde-systemtools.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/kde-systemtools.scm b/gnu/packages/kde-systemtools.scm
index bac044bf76..56ce37fea8 100644
--- a/gnu/packages/kde-systemtools.scm
+++ b/gnu/packages/kde-systemtools.scm
@@ -340,6 +340,59 @@ who want to quickly see problems occurring on their server.
 This package is part of the KDE administration module.")
     (license license:gpl2+)))
 
+(define-public spectacle
+  (package
+    (name "spectacle")
+    (version "23.04.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/" version
+                           "/src/spectacle-" version ".tar.xz"))
+       (sha256
+        (base32 "1fyklcvz0zndxabflkka75rham6768rp01as7m5dv0ic4lipkf9m"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "ctest" "-E"
+                             "filename_test")))))))
+    (native-inputs
+     (list extra-cmake-modules kdoctools))
+    (inputs
+     (list kconfig
+           kcoreaddons
+           kdbusaddons
+           kglobalaccel
+           kguiaddons
+           ki18n
+           kio
+           kirigami
+           knotifications
+           kpipewire
+           kwidgetsaddons
+           kwindowsystem
+           kxmlgui
+           libxcb
+           purpose
+           qtdeclarative-5
+           qtquickcontrols2-5
+           qtwayland-5
+           qtx11extras
+           wayland
+           wayland-protocols
+           plasma-wayland-protocols
+           xcb-util
+           xcb-util-cursor
+           xcb-util-image))
+    (home-page "https://apps.kde.org/spectacle/")
+    (synopsis "Screenshot capture utility for KDE")
+    (description "Spectacle is a screenshot taking utility for the KDE.")
+    (license license:gpl2+)))
+
 (define-public yakuake
   (package
     (name "yakuake")