summary refs log tree commit diff
path: root/gnu/packages/kde-systemtools.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2022-02-06 18:32:30 +1100
committerMarius Bakke <marius@gnu.org>2022-09-01 17:24:00 +0200
commitbf771c9e96a807eae267b1678fac3750297769b6 (patch)
treea1727f2556a9dd22f37429f67356e968c7904524 /gnu/packages/kde-systemtools.scm
parent8cfe7e0321082cff2f7b207c4bd5c34443589299 (diff)
downloadguix-bf771c9e96a807eae267b1678fac3750297769b6.tar.gz
gnu: khelpcenter: Fix program.
* gnu/packages/kde-systemtools.scm (khelpcenter): Wrap XDG_DATA_DIRS to
point to khtml where it can find the html4.css file, otherwise
khelpcenter fails to launch.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-systemtools.scm')
-rw-r--r--gnu/packages/kde-systemtools.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/kde-systemtools.scm b/gnu/packages/kde-systemtools.scm
index b79f72a4ed..809a9ddb7a 100644
--- a/gnu/packages/kde-systemtools.scm
+++ b/gnu/packages/kde-systemtools.scm
@@ -160,7 +160,17 @@ Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
            qtbase-5
            xapian))
     (arguments
-     `(#:tests? #f)) ;; 1/1 test fails
+     `(#:tests? #f  ;; 1/1 test fails
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-executable
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out")))
+               ;; Since qt-wrap selectors do not wrap for /share/kf5
+               ;; directories, we need this so khelpcenter can find html4.css.
+               (wrap-program (string-append out "/bin/khelpcenter")
+                 `("XDG_DATA_DIRS" suffix
+                   (,(string-append (assoc-ref inputs "khtml") "/share"))))))))))
     (home-page "https://apps.kde.org/khelpcenter/")
     (synopsis "KDE documentation viewer")
     (description "KHelpCenter uses meta data files which describe the