summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-10 21:44:54 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-10 22:18:20 +0100
commit38988dbecf9e1ee83258c5625bb8fdacff82ed3d (patch)
treec1f68f195017bb2286b11d9739b40b7fbad430ca /gnu/packages/kde.scm
parent15cd7067537b9fdae21e7ca7b9e25da4a6476c14 (diff)
downloadguix-38988dbecf9e1ee83258c5625bb8fdacff82ed3d.tar.gz
gnu: kpmcore: Update to 4.0.1.
* gnu/packages/kde.scm(kpmcore): Update to 4.0.1. [origin]: Add upstream
  patches for making tests pass.  [inputs]: Add qttools.  Remove kiconthemes,
  kservice, libatasmart, parted. [arguments]: New element.

* gnu/packages/patches/kpmcore-fix-tests.patch,
  gnu/packages/patches/kpmcore-remove-broken-test.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.

add patches
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index e81224e8c0..9755f66aca 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -30,6 +30,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix utils)
+  #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages apr)
   #:use-module (gnu packages boost)
@@ -470,7 +471,7 @@ cards.")
 (define-public kpmcore
   (package
     (name "kpmcore")
-    (version "3.3.0")
+    (version "4.0.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -479,20 +480,19 @@ cards.")
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0s6v0jfrhjg31ri5p6h9n4w29jvasf5dj954j3vfpzl91lygmmmq"))))
+                "1sslkwcj2cyrn7bpjdjdwikp1q8wrsxpsg2sxxd8hsairgy7ygh3"))
+              (patches (search-patches "kpmcore-fix-tests.patch"
+                                       "kpmcore-remove-broken-test.patch"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("kconfigwidgets" ,kconfigwidgets)
-       ("kiconthemes" ,kiconthemes)
        ("kio" ,kio)
        ("ki18n" ,ki18n)
-       ("kservice" ,kservice)
-       ("libatasmart" ,libatasmart)
-       ("parted" ,parted)
        ("qtbase" ,qtbase)
+       ("qca" ,qca)
        ("util-linux" ,util-linux)))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Library for managing partitions")