summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-20 22:24:11 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-28 13:08:38 +0100
commit156221051627a5c5737ba8e211d23c2adb80d7e2 (patch)
treee44cbd8383c71bb17d30757dbf53f9849ce579df /gnu/packages/kde.scm
parentcd165d105a35da9094b70d0e5d5320a4a6ac8c0d (diff)
downloadguix-156221051627a5c5737ba8e211d23c2adb80d7e2.tar.gz
gnu: Add baloo-widgets.
* gnu/packages/kde.scm (baloo-widgets): New variable.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 0c62fd9dba..8a612bfe5b 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -67,6 +67,39 @@
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public baloo-widgets
+  (package
+    (name "baloo-widgets")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/baloo-widgets-" version ".tar.xz"))
+       (sha256
+        (base32 "0bba8dgxd7rcjji809kwnw78hl1nb5ssh2ir4k4b0wvx395jifgd"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("baloo" ,baloo)
+       ("kconfig" ,kconfig)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("qtbase" ,qtbase)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'check-setup
+           (lambda _
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
+    (home-page "https://community.kde.org/Baloo")
+    (synopsis "Wigets for use with Baloo")
+    (description "Baloo is a framework for searching and managing metadata.
+This package contains GUI widgets for baloo.")
+    (license license:lgpl2.0+)))
+
 (define-public grantleetheme
   (package
     (name "grantleetheme")