summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorPrafulla Giri <pratheblackdiamond@gmail.com>2020-09-09 14:02:24 +0545
committerLudovic Courtès <ludo@gnu.org>2020-09-14 23:04:11 +0200
commite33a1e546a52aa70ffe0c8389f29ff3288cc4510 (patch)
tree0735bc97b392f1a7a1316711f2b679b72d13a3fd /gnu/packages/kde.scm
parent0d63abebd149de0c5261ea12cbf7d5850ace5aee (diff)
downloadguix-e33a1e546a52aa70ffe0c8389f29ff3288cc4510.tar.gz
gnu: kde: kdenlive: Make breeze theme available at runtime.
* gnu/packages/kde.scm (kdenlive):
[inputs]: Add breeze.
[arguments]: In wrap-program phase, add XDG_DATA_DIRS to include
the 'share' sub-directory of the package breeze.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index a9ac23e049..b22c3f0d8f 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -177,6 +177,7 @@ This package contains GUI widgets for baloo.")
          ("qtquickcontrols" ,qtquickcontrols)
          ("qtquickcontrols2" ,qtquickcontrols2)
          ("kiconthemes" ,kiconthemes)
+         ("breeze" ,breeze)
          ("qtgraphicaleffects" ,qtgraphicaleffects)
          ("kplotting" ,kplotting)))
       (arguments
@@ -192,10 +193,13 @@ This package contains GUI widgets for baloo.")
                       (qtdeclarative (assoc-ref inputs "qtdeclarative"))
                       (frei0r (assoc-ref inputs "frei0r-plugins"))
                       (ffmpeg (assoc-ref inputs "ffmpeg"))
+                      (breeze (assoc-ref inputs "breeze"))
                       (qml "/lib/qt5/qml"))
                  (wrap-program (string-append out "/bin/kdenlive")
                    `("PATH" ":" prefix
                      ,(list (string-append ffmpeg "/bin")))
+                   `("XDG_DATA_DIRS" ":" prefix
+                     ,(list (string-append breeze "/share")))
                    `("QT_PLUGIN_PATH" ":" prefix
                      ,(map (lambda (label)
                              (string-append (assoc-ref inputs label)