summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2022-10-08 00:47:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-10-08 00:49:12 -0400
commitc9d955d51e1c64b9ee51bda48503c2cced997945 (patch)
treed502bab09a4706a0a7f43018998735bd95644195 /gnu/packages/kde.scm
parent2cdd60dea14224344f00586199fa16210886d853 (diff)
downloadguix-c9d955d51e1c64b9ee51bda48503c2cced997945.tar.gz
gnu: Add ktimer.
* gnu/packages/kde.scm (ktimer): New variable.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index f187c02ba4..20df62fdfa 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -898,6 +898,33 @@ charts.")
 partitions, floppy and CD drives, etc.) along with information on their
 capacity, free space, type and mount point.  It also allows you to mount and
 unmount drives and view them in a file manager.")
+(license license:gpl2+)))
+
+(define-public ktimer
+  (package
+    (name "ktimer")
+    (version "20.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/release-service/" version
+                                  "/src/ktimer-" version ".tar.xz"))
+              (sha256
+               (base32
+                "12fz5v5ky03h18jl75fnq1zagjq8qzi1s1q7phjz5d1rbhwc57ls"))))
+    (build-system qt-build-system)
+    (native-inputs
+     (list extra-cmake-modules
+           kdoctools))
+    (inputs
+     (list kdbusaddons
+           ki18n
+           kio
+           knotifications))
+    (home-page "https://kde.org/applications/utilities/ktimer")
+    (synopsis "Countdown Launcher")
+    (description "KTimer is a little tool to execute programs after some time.
+It allows you to enter several tasks and to set a timer for each of them.  The
+timers for each task can be started, stopped, changed, or looped.")
     (license license:gpl2+)))
 
 (define-public kcachegrind