summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-06 09:56:48 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-23 18:14:17 +0100
commitb2fdd0cf4ade20b3d9bf0b249b32e06e9f8bf1b0 (patch)
treec25114e3b50eb382d859a663a070c9bcdd2c604c /gnu/packages/kde.scm
parent50bdf004388f3d12ddcbfd0dc7f17c4086cea8bb (diff)
downloadguix-b2fdd0cf4ade20b3d9bf0b249b32e06e9f8bf1b0.tar.gz
gnu: Add grantleetheme.
* gnu/packages/kde.scm (grantleetheme): New variable.
* gnu/packages/patches/grantlee-merge-theme-dirs.patch: New file.
* gnu:lokal.mk (DATA): Add it.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 82116610ec..31b917d033 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -64,8 +64,44 @@
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages video)
   #:use-module (gnu packages xdisorg)
+  #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public grantleetheme
+  (package
+    (name "grantleetheme")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/grantleetheme-" version ".tar.xz"))
+       (sha256
+        (base32 "0j77q1yyfmggzgkqgcw2xr0v9xg3h5cdhh8jry8h2llw75ahy6xb"))
+       (patches (search-patches "grantlee-merge-theme-dirs.patch"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("libxml2" ,libxml2))) ;; xmllint required for tests
+    (inputs
+     `(("grantlee" ,grantlee)
+       ("ki18n" ,ki18n)
+       ("kiconthemes" ,kiconthemes)
+       ("knewstuff" ,knewstuff)
+       ("qtbase" ,qtbase)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'check-setup
+           (lambda _
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
+    (home-page "https://cgit.kde.org/grantleetheme.git")
+    (synopsis "Library providing Grantlee theme support")
+    (description "This library provides Grantlee theme support.")
+    (license ;; LGPL for libraries, FDL for documentation
+     (list license:lgpl2.0+ license:fdl1.2+))))
+
 (define-public kdenlive
   (let ((version "18.08.1"))
     (package