summary refs log tree commit diff
path: root/gnu/packages/kerberos.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-24 22:29:56 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:07 +0000
commit527455be35c33e25cc76805a6f879d85a3624339 (patch)
tree2a73e449beb715a6bc3329d4f9a1ca5b72ca496f /gnu/packages/kerberos.scm
parentf706689a8d9da4abff783c71beb0b4eb4eb5615d (diff)
downloadguix-527455be35c33e25cc76805a6f879d85a3624339.tar.gz
gnu: heimdal: Refer to cross-compiled bash.
* gnu/packages/kerberos.scm
  (heimdal)[arguments]<#:phases>{pre-configure}: Let "appl/afsutil/pagsh.c"
  refer to the cross-compiled bash instead of the native bash when
  cross-compiling.
Diffstat (limited to 'gnu/packages/kerberos.scm')
-rw-r--r--gnu/packages/kerberos.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index 54dd5dffc1..9afc6a363f 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -231,11 +231,24 @@ After installation, the system administrator should generate keys using
                                 '()))
        #:phases (modify-phases %standard-phases
                   (add-before 'configure 'pre-configure
-                    (lambda _
-                      (substitute* '("appl/afsutil/pagsh.c"
-                                     "tools/Makefile.in")
-                        (("/bin/sh") (which "sh")))
-                      #t))
+                    ;; TODO(core-updates): Unconditionally use the
+                    ;; %current-target-system branch.
+                    (,(if (%current-target-system)
+                          'lambda*
+                          'lambda)
+                     ,(if (%current-target-system)
+                          '(#:key inputs #:allow-other-keys)
+                          '_)
+                     ,@(if (%current-target-system)
+                           '((substitute* '("appl/afsutil/pagsh.c")
+                               (("/bin/sh")
+                                (search-input-file inputs "bin/sh")))
+                             (substitute* '("tools/Makefile.in")
+                               (("/bin/sh") (which "sh"))))
+                           '((substitute* '("appl/afsutil/pagsh.c"
+                                            "tools/Makefile.in")
+                               (("/bin/sh") (which "sh")))
+                             #t))))
                   (add-before 'check 'pre-check
                     (lambda _
                       ;; For 'getxxyyy-test'.