summary refs log tree commit diff
path: root/gnu/packages/kerberos.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-09 11:35:18 +0200
committerMarius Bakke <marius@gnu.org>2021-05-09 23:43:31 +0200
commit0689e1abed095c9eb971427846de9e9deb20dc59 (patch)
tree3954aef62a0395e0a76a22fc193dfd10d9f4f4f2 /gnu/packages/kerberos.scm
parent5492b1b50cccf00de6b2581349cc63c50c0787c0 (diff)
downloadguix-0689e1abed095c9eb971427846de9e9deb20dc59.tar.gz
gnu: mit-krb5: Update to 1.19.1.
* gnu/packages/patches/mit-krb5-hurd.patch: Adjust for 1.19.1.
* gnu/packages/patches/mit-krb5-qualify-short-hostnames.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/kerberos.scm (mit-krb5): Update to 1.19.1.
[source](patches): Remove obsolete patch.
[arguments]: Remove trailing #t's and one obsolete subtitution.
Diffstat (limited to 'gnu/packages/kerberos.scm')
-rw-r--r--gnu/packages/kerberos.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index 0f3ff96388..5065f3be17 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -54,7 +54,7 @@
 (define-public mit-krb5
   (package
     (name "mit-krb5")
-    (version "1.18")
+    (version "1.19.1")
     (source (origin
               (method url-fetch)
               (uri (list
@@ -64,11 +64,10 @@
                     (string-append "https://kerberos.org/dist/krb5/"
                                    (version-major+minor version)
                                    "/krb5-" version ".tar.gz")))
-              (patches (search-patches "mit-krb5-qualify-short-hostnames.patch"
-                                       "mit-krb5-hurd.patch"))
+              (patches (search-patches "mit-krb5-hurd.patch"))
               (sha256
                (base32
-                "121c5xsy3x0i4wdkrpw62yhvji6virbh6n30ypazkp0isws3k4bk"))))
+                "02xjpsfy84l6v7vjlxzhrl6mx2zrmxz0v01w2j33bv73nxzgh5ps"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)
@@ -99,20 +98,14 @@
        (modify-phases %standard-phases
          (add-after 'unpack 'enter-source-directory
            (lambda _
-             (chdir "src")
-             #t))
+             (chdir "src")))
          (add-before 'check 'pre-check
            (lambda* (#:key inputs native-inputs #:allow-other-keys)
              (let ((perl (assoc-ref (or native-inputs inputs) "perl")))
                (substitute* "plugins/kdb/db2/libdb2/test/run.test"
                  (("/bin/cat") (string-append perl "/bin/perl"))
                  (("D/bin/sh") (string-append "D" (which "sh")))
-                 (("bindir=/bin/.") (string-append "bindir=" perl "/bin"))))
-
-             ;; avoid service names since /etc/services is unavailable
-             (substitute* "tests/resolve/Makefile"
-               (("-p telnet") "-p 23"))
-             #t)))))
+                 (("bindir=/bin/.") (string-append "bindir=" perl "/bin")))))))))
     (synopsis "MIT Kerberos 5")
     (description
      "Massachusetts Institute of Technology implementation of Kerberos.