summary refs log tree commit diff
path: root/gnu/packages/kodi.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-24 08:28:46 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-30 22:32:37 +0200
commit8c0117371a163240a487a6eee3d7992a9df327ea (patch)
tree7f360e629a504cafb1a672d46d5c30f5091753f4 /gnu/packages/kodi.scm
parentc3c25082e820fc3e376a757a48124924b92d816a (diff)
downloadguix-8c0117371a163240a487a6eee3d7992a9df327ea.tar.gz
gnu: kodi: Embed full path to tzdata.
* gnu/packages/kodi.scm (kodi)[arguments]: Add substitution for tzdata in
'patch-stuff' phase.
[inputs]: Add TZDATA.
Diffstat (limited to 'gnu/packages/kodi.scm')
-rw-r--r--gnu/packages/kodi.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index a60e2c0548..4845c6624d 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -302,7 +302,7 @@ generator library for C++.")
                           (zero? (system* "autoreconf" "-vif"))))
                       dirs))))
          (add-after 'bootstrap-bundled-software 'patch-stuff
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
              ;; Prevent the build scripts from calling autoreconf in the
              ;; build stage.  Otherwise, it would undo the bootstrapping
              ;; and shebang patching that we worked so hard for.
@@ -316,6 +316,11 @@ generator library for C++.")
                ;; to make them writable before the build process starts.
                (("autoreconf -vif") "chmod -R u+w ."))
 
+             (substitute* "xbmc/linux/LinuxTimezone.cpp"
+               (("/usr/share/zoneinfo")
+                (string-append (assoc-ref inputs "tzdata")
+                               "/share/zoneinfo")))
+
              ;; Let's disable some tests that are known not to work here.
              ;; Doing this later while in the cmake "../build" directory
              ;; is trickier.
@@ -416,6 +421,7 @@ generator library for C++.")
        ("sqlite" ,sqlite)
        ("taglib" ,taglib)
        ("tinyxml" ,tinyxml)
+       ("tzdata" ,tzdata)
        ("util-linux" ,util-linux)
        ("zip" ,zip)
        ("zlib" ,zlib)))