summary refs log tree commit diff
path: root/gnu/packages/ldc.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-01-05 15:43:50 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-05 16:24:57 +0100
commita7ec569c98af8a1c310a32e19f0c01cdd7334af6 (patch)
tree6b760a9d63077b46ab4d8a78f663f3874d26a379 /gnu/packages/ldc.scm
parent1075b43737825e3eea24e31ad02142c45747d4bb (diff)
downloadguix-a7ec569c98af8a1c310a32e19f0c01cdd7334af6.tar.gz
gnu: Add LDC.
* gnu/packages/ldc.scm: New file.
* gnu/packages/patches/ldc-disable-tests.patch: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add ldc.scm.
  (dist_patch_DATA): Add patch file.
Diffstat (limited to 'gnu/packages/ldc.scm')
-rw-r--r--gnu/packages/ldc.scm118
1 files changed, 118 insertions, 0 deletions
diff --git a/gnu/packages/ldc.scm b/gnu/packages/ldc.scm
new file mode 100644
index 0000000000..06040a2b92
--- /dev/null
+++ b/gnu/packages/ldc.scm
@@ -0,0 +1,118 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2015 Pjotr Prins <pjotr.guix@thebird.nl>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ldc)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system cmake)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages libedit)
+  #:use-module (gnu packages llvm)
+  #:use-module (gnu packages textutils)
+  #:use-module (gnu packages zip))
+
+(define-public ldc
+  (package
+    (name "ldc")
+    (version "0.16.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/ldc-developers/ldc/archive/v"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1jvilxx0rpqmkbja4m69fhd5g09697xq7vyqp2hz4hvxmmmv4j40"))))
+    (build-system cmake-build-system)
+    ;; LDC currently only supports the x86_64 and i686 architectures.
+    (supported-systems '("x86_64-linux" "i686-linux"))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'unpack-submodule-sources
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((unpack (lambda (source target)
+                             (with-directory-excursion target
+                               (zero? (system* "tar" "xvf"
+                                               (assoc-ref inputs source)
+                                               "--strip-components=1"))))))
+               (and (unpack "phobos-src" "runtime/phobos")
+                    (unpack "druntime-src" "runtime/druntime")
+                    (unpack "dmd-testsuite-src" "tests/d2/dmd-testsuite")))))
+         (add-after 'unpack-submodule-sources 'patch-phobos
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "runtime/phobos/std/process.d"
+               (("/bin/sh") (which "sh"))
+               (("echo") (which "echo")))
+             (substitute* "runtime/phobos/std/datetime.d"
+               (("/usr/share/zoneinfo/")
+                (string-append (assoc-ref inputs "tzdata") "/share/zoneinfo")))
+             (substitute* "tests/d2/dmd-testsuite/Makefile"
+               (("/bin/bash") (which "bash")))
+             #t)))))
+    (inputs
+     `(("libconfig" ,libconfig)
+       ("libedit" ,libedit)
+       ("tzdata" ,tzdata)))
+    (native-inputs
+     `(("llvm" ,llvm)
+       ("clang" ,clang)
+       ("unzip" ,unzip)
+       ("phobos-src"
+        ,(origin
+           (method url-fetch)
+           (uri (string-append
+                 "https://github.com/ldc-developers/phobos/archive/ldc-v"
+                 version ".tar.gz"))
+           (sha256
+            (base32
+             "0sgdj0536c4nb118yiw1f8lqy5d3g3lpg9l99l165lk9xy45l9z4"))
+           (patches (list (search-patch "ldc-disable-tests.patch")))))
+       ("druntime-src"
+        ,(origin
+           (method url-fetch)
+           (uri (string-append
+                 "https://github.com/ldc-developers/druntime/archive/ldc-v"
+                 version ".tar.gz"))
+           (sha256
+            (base32
+             "0z4mkyddx6c4sy1vqgqvavz55083dsxws681qkh93jh1rpby9yg6"))))
+       ("dmd-testsuite-src"
+        ,(origin
+           (method url-fetch)
+           (uri (string-append
+                 "https://github.com/ldc-developers/dmd-testsuite/archive/ldc-v"
+                 version ".tar.gz"))
+           (sha256
+            (base32
+             "0yc6miidzgl9k33ygk7xcppmfd6kivqj02cvv4fmkbs3qz4yy3z1"))))))
+    (home-page "http://wiki.dlang.org/LDC")
+    (synopsis "LLVM compiler for the D programming language")
+    (description
+     "LDC is a compiler for the D programming language.  It is based on the
+latest DMD frontend and uses LLVM as backend.")
+    ;; Most of the code is released under BSD-3, except for code originally
+    ;; written for GDC, which is released under GPLv2+, and the DMD frontend,
+    ;; which is released under the "Boost Software License version 1.0".
+    (license (list license:bsd-3
+                   license:gpl2+
+                   license:x11-style "http://www.boost.org/LICENSE_1_0.txt"))))