summary refs log tree commit diff
path: root/gnu/packages/lean.scm
diff options
context:
space:
mode:
authorAmin Bandali <bandali@gnu.org>2019-12-28 01:29:01 -0500
committerBrett Gilio <brettg@gnu.org>2020-01-03 15:46:53 -0600
commitdb1bc0d92e4a023d2b22487c324410e8dc4cda1f (patch)
treeb28944262b62c81801f1a5cc1a51b10d22d522b4 /gnu/packages/lean.scm
parent13e3bc1c800b531d33bc64a1fea64a66dc5f9300 (diff)
downloadguix-db1bc0d92e4a023d2b22487c324410e8dc4cda1f.tar.gz
gnu: Add lean.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add lean.scm.
* gnu/packages/lean.scm: New file.

Signed-off-by: Brett Gilio <brettg@gnu.org>
Diffstat (limited to 'gnu/packages/lean.scm')
-rw-r--r--gnu/packages/lean.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/lean.scm b/gnu/packages/lean.scm
new file mode 100644
index 0000000000..235113d475
--- /dev/null
+++ b/gnu/packages/lean.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages lean)
+  #:use-module (gnu packages multiprecision)
+  #:use-module (guix build-system cmake)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix git-download))
+
+(define-public lean
+  (package
+    (name "lean")
+    (version "3.5.0")
+    (home-page "https://github.com/leanprover-community/lean")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference (url home-page)
+                                  (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1fdblq8ckrv6wqxfl4ybcs3ybfq7y096c9f5j4j75ymb14r401lr"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("gmp" ,gmp)))
+    (arguments
+     `(#:build-type "Release"           ; default upstream build type
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-source-shebangs 'patch-tests-shebangs
+           (lambda _
+             (let ((sh (which "sh"))
+                   (bash (which "bash")))
+               (substitute* (find-files "tests/lean" "\\.sh$")
+                 (("#![[:blank:]]?/bin/sh")
+                  (string-append "#!" sh))
+                 (("#![[:blank:]]?/bin/bash")
+                  (string-append "#!" bash))
+                 (("#![[:blank:]]?usr/bin/env bash")
+                  (string-append "#!" bash)))
+               #t)))
+         (add-before 'configure 'chdir-to-src
+           (lambda _ (chdir "src") #t)))))
+    (synopsis "The Lean theorem prover and programming language")
+    (description
+     "Lean is a theorem prover and programming language with a small trusted
+core based on dependent typed theory, aiming to bridge the gap between
+interactive and automated theorem proving.")
+    (license license:asl2.0)))