summary refs log tree commit diff
path: root/gnu/packages/less.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 03:49:35 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 11:19:56 +0100
commit5052829f1c11cc474d9738eeb1833d6cd3b46476 (patch)
tree14fee54689e8916dd58f1b2460aaf11c74841b35 /gnu/packages/less.scm
parent084e675ac884a27123e1198a08114d35f438f06e (diff)
downloadguix-5052829f1c11cc474d9738eeb1833d6cd3b46476.tar.gz
gnu: lesspipe: Update to 1.90.
* gnu/packages/less.scm (lesspipe): Update to 1.90.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/less.scm')
-rw-r--r--gnu/packages/less.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/less.scm b/gnu/packages/less.scm
index 25b675902a..4c8552c004 100644
--- a/gnu/packages/less.scm
+++ b/gnu/packages/less.scm
@@ -59,7 +59,7 @@ text editors.")
 (define-public lesspipe
   (package
     (name "lesspipe")
-    (version "1.89")
+    (version "1.90")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -68,7 +68,7 @@ text editors.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0lxf0m4bgwhpwmwa5q2vklk31yhiaz049kpm4n2hqiyb5mlpa94a"))))
+                "17gv4nr9fxrk3png477pgiimdz8minp9scmqg2nxa96jfz4sk4li"))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f                      ; no tests
@@ -79,8 +79,7 @@ text editors.")
                         (delete-file "Makefile") ; force generating
                         (invoke "./configure"
                                 (string-append "--prefix=" out)
-                                "--yes")
-                        #t)))
+                                "--yes"))))
                   (add-before 'install 'patch-tput-and-file
                     (lambda* (#:key inputs #:allow-other-keys)
                       (substitute* "lesspipe.sh"
@@ -89,8 +88,7 @@ text editors.")
                                         "/bin/tput colors"))
                         (("file -")
                          (string-append (assoc-ref inputs "file")
-                                        "/bin/file -")))
-                      #t)))))
+                                        "/bin/file -"))))))))
     (inputs
      `(("file" ,file)
        ("ncurses" ,ncurses)))  ; for tput