summary refs log tree commit diff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-26 14:21:19 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-26 19:48:39 +0200
commit7024846181a24e32343d49a192cca4be96b1e1ca (patch)
treef6cabcf61d793dfcfc4d228be732c34a551978dc /gnu/packages/libevent.scm
parent0d3dbe3f56949ad07d8a3816a8a884d3726d2c7d (diff)
downloadguix-7024846181a24e32343d49a192cca4be96b1e1ca.tar.gz
gnu: node: Update to 10.15.3.
* gnu/packages/libevent.scm (libuv-1.19): Remove variable.
* gnu/packages/node.scm (node): Update to 10.15.3.
[source]: Use XZ-compressed tarball.
[arguments]: Add #:test-target.  Use DELETE-FILE instead of DELETE-IF-EXISTS.
Remove obsolete test deletions.
[inputs]: Change OPENSSL to OPENSSL-NEXT.  Change LIBUV-1.19 to LIBUV.
(node-lts): Remove variable.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 72227c1d95..bb96fd6abf 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -150,19 +150,6 @@ resolution, asynchronous file system operations, and threading primitives.")
     ;; details.  Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
     (license (list expat cc-by4.0))))
 
-;; This version is required for Node versions < 10.
-(define-public libuv-1.19
-  (package
-    (inherit libuv)
-    (version "1.19.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://dist.libuv.org/dist/v" version
-                                  "/libuv-v" version ".tar.gz"))
-              (sha256
-               (base32
-                "1msk9ac1z69whww88ibrwjqkd1apdla6l77cm2fwy5kigq0z5g3w"))))))
-
 (define-public perl-anyevent
   (package
     (name "perl-anyevent")