summary refs log tree commit diff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-19 15:23:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-28 14:24:08 +0100
commit61bed157075b23bc29d6859e4755ebaafac0d77a (patch)
treef26ea7b24122ec0e4e77a89c701d8e2b8b4387cc /gnu/packages/libevent.scm
parent48a064a379cca579af45ad3a538b104cd5574fae (diff)
downloadguix-61bed157075b23bc29d6859e4755ebaafac0d77a.tar.gz
gnu: libuv: Use 'modify-phases' syntax.
* gnu/packages/libevent.scm (libuv)[arguments]<#:phases>: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 0b87011ffc..c0c7688fa2 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -131,13 +131,12 @@ programs.")
                 "0pbq9kb96fp131fcmmpjngh8n4nsnwafzirdi8j934wnmnlsyjnn"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-cons-after
-                 'unpack 'autogen
-                 (lambda _
-                   ;; Fashionable people don't run 'make dist' these days, so
-                   ;; we need to do that ourselves.
-                   (zero? (system* "sh" "autogen.sh")))
-                 %standard-phases)
+     '(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'autogen
+                    (lambda _
+                      ;; Fashionable people don't run 'make dist' these days, so
+                      ;; we need to do that ourselves.
+                      (zero? (system* "sh" "autogen.sh")))))
 
        ;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
        #:tests? #f))