summary refs log tree commit diff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-08 12:06:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-08 19:53:16 +0200
commit02d591206259b30462764cb2f978ae214dea0449 (patch)
tree4622c1683b0c32a677700326bcefb249cc247b22 /gnu/packages/libevent.scm
parent7d8f92dd87e6f13ec6b87744c3db9bb3be541707 (diff)
downloadguix-02d591206259b30462764cb2f978ae214dea0449.tar.gz
gnu: julia: Update to 1.8.3.
* gnu/packages/julia.scm (julia): Update to 1.8.3.
[source]: Remove one patch.
[arguments]: Adjust 'prepare-deps phase to changes in inputs. Remove
custom 'use-system-libwhich, 'change-number-of-precompiled-statements,
'symlink-libraries phases. In 'fix-include-and-link-paths phase remove
substitution for utf8proc linking and adjust libuv linking. Fix
reference to shell in 'replace-default-shell phase. Adjust the
'shared-objects-path phase to changes in the source. Change the
'enable-parallel-tests phase for upstream changes. Adjust the
'adjust-test-suite phase to be more robust. Change the
'disable-broken-tests phase to help the test suite pass. Rename
'symlink-llvm-utf8proc phase to 'symlink-missing-libraries and add two
more. Adjust make-flags for changes in shared system libraries. Reorder
make-flags to changes in the source. Except for aarch64, use the
defaults for choosing to use 64-bit blas.
[inputs]: Add libblastrampoline. Replace libgit-1.1 with libgit-1.3,
utf8proc-2.7.1 with utf8proc-2.8.0.
[native-inputs]: Replace python-2 with python.
(libunwind-julia): Update to 1.5.0.
[source]: Update patches.
* gnu/packages/libevent.scm (libuv-julia): Update to 2.0.0-4.e6f0e49.
[arguments]: Also build static library, build position-independent-code.
* gnu/packages/llvm.scm (llvm-julia): Update to llvm-13, following
upstream's build instructions.
* gnu/packages/maths.scm (openlibm): Update to 0.8.1.
* gnu/packages/textutils.scm (utf8proc-2.7.1): Update and rename to
utf8proc-2.8.0.
[native-inputs]: Update unicode to 14.0.0.
* gnu/packages/tls.scm (mbedtls-apache): Update to 2.28.0.
[source]: Remove snippet.
[arguments]: Remove trailing #t from phases.
* gnu/packages/patches/julia-allow-parallel-build.patch,
(julia-patch): Update version string to 1.8.2.
gnu/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch: Remove
files.
* gnu/local.mk (dist_patch_DATA): Remove them.

Co-authored-by: Akira Kyle <akira@akirakyle.com>
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 176e66cf42..f9722e4469 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -158,10 +158,10 @@ resolution, asynchronous file system operations, and threading primitives.")
     (properties '((hidden? . #t)))))
 
 (define-public libuv-julia
-  (let ((commit "fb3e3364c33ae48c827f6b103e05c3f0e78b79a9")
-        (revision "3"))
+  (let ((commit "e6f0e4900e195c8352f821abe2b3cffc3089547b")
+        (revision "4"))
     ;; When upgrading Julia, also upgrade this.  Get the commit from
-    ;; https://github.com/JuliaLang/julia/blob/v1.6.1/deps/libuv.version
+    ;; https://github.com/JuliaLang/julia/blob/v1.8.2/deps/libuv.version
     (package
       (inherit libuv)
       (name "libuv-julia")
@@ -174,7 +174,10 @@ resolution, asynchronous file system operations, and threading primitives.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1kqpn19d20aka30h6q5h8lnzyp0vw0xzgx0wm4w2r5j6yf76m2hr"))))
+                  "0ib2cprvbyviwrzm0fw6dqvlbm9akf2kj3vjzp82q3gii74cv3c9"))))
+      (arguments
+       '(#:configure-flags '("--with-pic")
+         #:tests? #f))
       (home-page "https://github.com/JuliaLang/libuv")
       (properties '((hidden? . #t))))))