summary refs log tree commit diff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-03-18 02:29:12 -0400
committerMark H Weaver <mhw@netris.org>2017-03-19 15:54:58 -0400
commit512fc6db7bb900a892810d4b3c8b0e712b8e2379 (patch)
tree5d44de567c16b9138d1cce2760e5216c379fc051 /gnu/packages/libevent.scm
parent26e34e1e1288d657e92372efb6edc95c0e299247 (diff)
downloadguix-512fc6db7bb900a892810d4b3c8b0e712b8e2379.tar.gz
gnu: libevent@2.0: Add fix from upstream.
This fix was cherry-picked by Mozilla from upstream libevent-2.1 to its
bundled copy of libevent-2.0.21 in mozilla-esr45.

* gnu/packages/patches/libevent-2.0-evbuffer-add-use-last-with-datap.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/libevent.scm (libevent-2.0)[source][patches]: Add it.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index dd5f7c4067..6e2ce8f257 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
@@ -74,18 +74,20 @@ loop.")
     (inherit libevent)
     (version "2.0.22")
     (source (origin
-          (method url-fetch)
-          (uri (string-append
-                "https://github.com/libevent/libevent/releases/download/release-"
-                version "-stable/libevent-" version "-stable.tar.gz"))
-          (sha256
-           (base32
-            "18qz9qfwrkakmazdlwxvjmw8p76g70n3faikwvdwznns1agw9hki"))
-          (patches (search-patches
-                    "libevent-dns-tests.patch"
-                    "libevent-2.0-evdns-fix-remote-stack-overread.patch"
-                    "libevent-2.0-evutil-fix-buffer-overflow.patch"
-                    "libevent-2.0-evdns-fix-searching-empty-hostnames.patch"))))))
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/libevent/libevent/releases/download/release-"
+                    version "-stable/libevent-" version "-stable.tar.gz"))
+              (sha256
+               (base32
+                "18qz9qfwrkakmazdlwxvjmw8p76g70n3faikwvdwznns1agw9hki"))
+              (patches
+               (search-patches
+                "libevent-dns-tests.patch"
+                "libevent-2.0-evdns-fix-remote-stack-overread.patch"
+                "libevent-2.0-evutil-fix-buffer-overflow.patch"
+                "libevent-2.0-evdns-fix-searching-empty-hostnames.patch"
+                "libevent-2.0-evbuffer-add-use-last-with-datap.patch"))))))
 
 (define-public libev
   (package