summary refs log tree commit diff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-01 18:28:45 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-01 22:38:25 +0100
commitfd05d7ecd9f021b6c52a6d27669188b44305c79d (patch)
tree86c6d8408df2ea598327362aad3ffa84f967f3d2 /gnu/packages/libevent.scm
parent47055b273a7d616ec4362e439287914b442797a3 (diff)
downloadguix-fd05d7ecd9f021b6c52a6d27669188b44305c79d.tar.gz
gnu: libevent: Skip tests that fail on 32bit.
* gnu/packages/patches/libevent-2.1-skip-failing-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/libevent.scm (libevent)[source]: Use it.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index ca59db390c..bef09f9538 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -43,7 +43,10 @@
              (sha256
               (base32
                "1hhxnxlr0fsdv7bdmzsnhdz16fxf3jg2r6vyljcl3kj6pflcap4n"))
-             (patches (search-patches "libevent-2.1-dns-tests.patch"))))
+             (patches (search-patches "libevent-2.1-dns-tests.patch"
+                                      ;; XXX: Try removing this for > 2.1.8.
+                                      ;; https://github.com/libevent/libevent/issues/452
+                                      "libevent-2.1-skip-failing-test.patch"))))
     (build-system gnu-build-system)
     (inputs
      `(("python" ,python-2)))           ; for 'event_rpcgen.py'