summary refs log tree commit diff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-14 16:24:34 +0200
committerMarius Bakke <marius@gnu.org>2020-06-14 16:24:34 +0200
commit4193095e18b602705df94e38a8d60ef1fe380e49 (patch)
tree2500f31bcfae9b4cb5a23d633395f6892a7bd8a7 /gnu/packages/libffi.scm
parenta48a3f0640d76cb5e5945557c9aae6dabce39d93 (diff)
parente88745a655b220b4047f7db5175c828ef9c33e11 (diff)
downloadguix-4193095e18b602705df94e38a8d60ef1fe380e49.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm64
1 files changed, 54 insertions, 10 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index e058692c99..97a3bebeba 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2015, 2019 Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
 ;;; Copyright © 2016, 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019, 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
@@ -28,6 +28,7 @@
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (gnu packages check)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -77,13 +78,13 @@ conversions for values passed between the two languages.")
 (define-public python-cffi
   (package
     (name "python-cffi")
-    (version "1.13.2")
+    (version "1.14.0")
     (source
      (origin
       (method url-fetch)
       (uri (pypi-uri "cffi" version))
       (sha256
-       (base32 "0iikq5rn9a405n94c7s2j6kq3jv5qs9q4xyik8657b2py27ix6jr"))))
+       (base32 "1dn279gw5ql8i5n3s5v4rnv96rhhjjfn7xq729qbl5bs2954yf1d"))))
     (build-system python-build-system)
     (inputs
      `(("libffi" ,libffi)))
@@ -183,17 +184,60 @@ project.")
 (define-public ruby-ffi
   (package
     (name "ruby-ffi")
-    (version "1.10.0")
+    (version "1.12.2")
     (source (origin
-              (method url-fetch)
-              (uri (rubygems-uri "ffi" version))
+              ;; Pull from git because the RubyGems release bundles LibFFI,
+              ;; and comes with a gemspec that makes it difficult to unbundle.
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ffi/ffi")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0j8pzj8raxbir5w5k6s7a042sb5k02pg0f8s4na1r5lan901j00p"))))
+                "1cvqsbjr2gfjgqggq9kdx90qhhzr7qkyr9wmxdsfsik6cnxnnpmd"))))
     (build-system ruby-build-system)
-    ;; FIXME: Before running tests the build system attempts to build libffi
-    ;; from sources.
-    (arguments `(#:tests? #f))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'do-not-depend-on-ccache
+           (lambda _
+             (substitute* "spec/ffi/fixtures/GNUmakefile"
+               (("^CCACHE := .*")
+                ""))
+             #t))
+         (replace 'replace-git-ls-files
+           (lambda _
+             ;; Do not try to execute git, or include the (un)bundled LibFFI.
+             (substitute* "ffi.gemspec"
+               (("git ls-files -z")
+                "find * -type f -print0 | sort -z")
+               (("lfs \\+?= .*")
+                "lfs = []\n"))
+             (substitute* "Rakefile"
+               (("LIBFFI_GIT_FILES = .*")
+                "LIBFFI_GIT_FILES = []\n"))
+             #t))
+         (replace 'build
+          (lambda _
+            ;; Tests depend on the native extensions, so we build it
+            ;; beforehand without going through the gem machinery.
+             (invoke "rake" "compile")
+
+             ;; XXX: Ideally we'd use "rake native gem" here to prevent the
+             ;; install phase from needlessly rebuilding everything, but that
+             ;; requires the bundled LibFFI, and the install phase can not
+             ;; deal with such gems anyway.
+             (invoke "gem" "build" "ffi.gemspec")))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (if tests?
+                 (begin
+                   (setenv "MAKE" "make")
+                   (setenv "CC" "gcc")
+                   (invoke "rspec" "spec"))
+                 (format #t "test suite not run~%"))
+             #t)))))
     (native-inputs
      `(("ruby-rake-compiler" ,ruby-rake-compiler)
        ("ruby-rspec" ,ruby-rspec)