summary refs log tree commit diff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-28 15:43:30 +0200
committerMarius Bakke <marius@gnu.org>2022-08-28 15:43:30 +0200
commitdedbaa3a69e8e4da419d62ce0022c1af02bbef5a (patch)
treea7ba03967c4765d73d8a24fc493e654ec15ac689 /gnu/packages/libffi.scm
parent5bfe389a6eb7727994b802d2aa8737c16fd78057 (diff)
parent57f8f69562e942557e3331bb81c7e4acd973d189 (diff)
downloadguix-dedbaa3a69e8e4da419d62ce0022c1af02bbef5a.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index f09a43db37..6d16e6a03b 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -171,28 +171,22 @@ project.")
 (define-public ruby-ffi
   (package
     (name "ruby-ffi")
-    (version "1.12.2")
+    (version "1.15.5")
     (source (origin
               ;; Pull from git because the RubyGems release bundles LibFFI,
               ;; and comes with a gemspec that makes it difficult to unbundle.
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/ffi/ffi")
-                    (commit version)))
+                    (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1cvqsbjr2gfjgqggq9kdx90qhhzr7qkyr9wmxdsfsik6cnxnnpmd"))))
+                "1qk55s1zwpdjykwkj9l37m71i5n228i7f8bg3ply3ks9py16m7s6"))))
     (build-system ruby-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'do-not-depend-on-ccache
-           (lambda _
-             (substitute* "spec/ffi/fixtures/GNUmakefile"
-               (("^CCACHE := .*")
-                ""))
-             #t))
          (replace 'replace-git-ls-files
            (lambda _
              ;; Do not try to execute git, or include the (un)bundled LibFFI.
@@ -202,9 +196,10 @@ project.")
                (("lfs \\+?= .*")
                 "lfs = []\n"))
              (substitute* "Rakefile"
+               (("git .*ls-files -z")
+                "find * -type f -print0 | sort -z")
                (("LIBFFI_GIT_FILES = .*")
-                "LIBFFI_GIT_FILES = []\n"))
-             #t))
+                "LIBFFI_GIT_FILES = []\n"))))
          (replace 'build
           (lambda _
             ;; Tests depend on the native extensions, so we build it
@@ -223,8 +218,7 @@ project.")
                    (setenv "MAKE" "make")
                    (setenv "CC" "gcc")
                    (invoke "rspec" "spec"))
-                 (format #t "test suite not run~%"))
-             #t)))))
+                 (format #t "test suite not run~%")))))))
     (native-inputs
      (list ruby-rake-compiler ruby-rspec ruby-rubygems-tasks))
     (inputs