summary refs log tree commit diff
path: root/gnu/packages/libidn.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-09-04 20:38:29 -0400
committerMark H Weaver <mhw@netris.org>2017-09-04 20:39:20 -0400
commitb8b0f536a4f9a26c1d4002ca54048db6d5e58760 (patch)
tree07ee9412ba088a09fb6a7a86316a9198786a26e4 /gnu/packages/libidn.scm
parenta913d9d9269b91b2b95d72e291c2dc62e163de7d (diff)
downloadguix-b8b0f536a4f9a26c1d4002ca54048db6d5e58760.tar.gz
gnu: libidn2: Replace with 2.0.4 [security fixes].
* gnu/packages/libidn.scm (libidn2)[replacement]: New field.
(libidn2-2.0.4): New variable.
Diffstat (limited to 'gnu/packages/libidn.scm')
-rw-r--r--gnu/packages/libidn.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/libidn.scm b/gnu/packages/libidn.scm
index fc91fe263e..dfb1be6c4f 100644
--- a/gnu/packages/libidn.scm
+++ b/gnu/packages/libidn.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -55,6 +56,7 @@ Java libraries.")
   (package
     (name "libidn2")
     (version "2.0.2")
+    (replacement libidn2-2.0.4)
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/libidn/" name "-" version
@@ -76,3 +78,16 @@ library.")
     ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
     ;; GPL2+ or LGPL3+.
     (license (list gpl2+ gpl3+ lgpl3+))))
+
+(define-public libidn2-2.0.4
+  (package
+    (inherit libidn2)
+    (name "libidn2")
+    (version "2.0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/libidn/" name "-" version
+                                  ".tar.lz"))
+              (sha256
+               (base32
+                "00f2fyw5kwr9is3cdn5h9arzxp0lnvg0z9bb9zyfs0dq81gaqim4"))))))