summary refs log tree commit diff
path: root/gnu/packages/libidn.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-30 18:20:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-30 18:22:52 +0300
commitbed19695244f46cd3b16ef974573efcb5f8326a5 (patch)
tree0c22ea987b2408aa818cb825ea26fe5b8e50729e /gnu/packages/libidn.scm
parent63adf0fd676f0a3522baf66532aa2266f166b1b4 (diff)
downloadguix-bed19695244f46cd3b16ef974573efcb5f8326a5.tar.gz
gnu: libidn2: Update to 2.0.4.
* gnu/packages/libidn.scm (libidn2): Update to 2.0.4.
[properties]: Add 'ftp-directory' to ease updates.
Diffstat (limited to 'gnu/packages/libidn.scm')
-rw-r--r--gnu/packages/libidn.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/libidn.scm b/gnu/packages/libidn.scm
index fc91fe263e..afd0b8dfe9 100644
--- a/gnu/packages/libidn.scm
+++ b/gnu/packages/libidn.scm
@@ -54,14 +54,14 @@ Java libraries.")
 (define-public libidn2
   (package
     (name "libidn2")
-    (version "2.0.2")
+    (version "2.0.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/libidn/" name "-" version
                                   ".tar.lz"))
               (sha256
                (base32
-                "0pqaj8d01aj4i110669fincqs10kgynyqcrmq2q7pss8v9dcd1jq"))))
+                "00f2fyw5kwr9is3cdn5h9arzxp0lnvg0z9bb9zyfs0dq81gaqim4"))))
     (native-inputs
      `(("lzip" ,lzip)))
     (inputs
@@ -73,6 +73,7 @@ the IDNA2008 specifications.   Libidn2 is believed to be a complete IDNA2008
 implementation, but has yet to be as extensively used as the original Libidn
 library.")
     (home-page "https://www.gnu.org/software/libidn/#libidn2")
+    (properties '((ftp-directory . "/gnu/libidn")))
     ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
     ;; GPL2+ or LGPL3+.
     (license (list gpl2+ gpl3+ lgpl3+))))