summary refs log tree commit diff
path: root/gnu/packages/libidn.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-11-06 03:29:06 -0500
committerMark H Weaver <mhw@netris.org>2016-11-06 03:29:06 -0500
commit8b6ad165d1fa479e5da2938d099dba356186e07c (patch)
treec30c024fd79497031c21c68d6c5688334d900467 /gnu/packages/libidn.scm
parent9422c98a0a2bf2c48d8e10e59d838ab23870eb10 (diff)
parent7f4658983a742072be4e28b227d6349461e9a68b (diff)
downloadguix-8b6ad165d1fa479e5da2938d099dba356186e07c.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/libidn.scm')
-rw-r--r--gnu/packages/libidn.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/libidn.scm b/gnu/packages/libidn.scm
index 0c9d0af3c8..bc67387b29 100644
--- a/gnu/packages/libidn.scm
+++ b/gnu/packages/libidn.scm
@@ -41,8 +41,31 @@
    (description
      "libidn is a library implementing of the Stringprep, Punycode and IDNA
 specifications.  These are used to encode and decode internationalized domain
-names.  It includes native C, C# and Java libraries.")
+names according to the IDNA2003 specifications.  It includes native C, C# and
+Java libraries.")
    ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
    ;; the command line tool is gpl3+.
    (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
    (home-page "http://www.gnu.org/software/libidn/")))
+
+(define-public libidn2
+  (package
+    (name "libidn2")
+    (version "0.11")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "ftp://alpha.gnu.org/gnu/libidn/libidn2-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1zxzhzx14q2b1xkx746pz4lawvqd8d055yy84n52ndwb4pf7nfax"))))
+    (build-system gnu-build-system)
+    (synopsis "Internationalized domain name library for IDNA2008")
+    (description "Libidn2 is an internationalized domain library implementing
+the IDNA2008 specifications.   Libidn2 is believed to be a complete IDNA2008
+implementation, but has yet to be as extensively used as the original Libidn
+library.")
+    (home-page "https://www.gnu.org/software/libidn/#libidn2")
+    ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
+    ;; GPL2+ or LGPL3+.
+    (license (list gpl2+ gpl3+ lgpl3+))))