summary refs log tree commit diff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-14 17:24:03 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-14 17:24:03 +0200
commit3736a110bd60e2453dc51e405d36fed51d4cb9b2 (patch)
tree48abcd3e1d64d63d219340ed71d57bff79206fe4 /gnu/packages/libreoffice.scm
parent5df4f48e95f418105228ed2c14529bfa76359bf3 (diff)
downloadguix-3736a110bd60e2453dc51e405d36fed51d4cb9b2.tar.gz
gnu: Add libcmis.
* gnu/packages/libreoffice.scm (libcmis): New variable.

Co-authored-by: John Darrington <jmd@gnu.org>
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 539600a12b..736da39919 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -26,10 +26,13 @@
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages curl)
+  #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages doxygen)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages icu4c)
+  #:use-module (gnu packages openssl)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -202,6 +205,47 @@ ZVR (simple compressed text format).")
 working with graphics in the WPG (WordPerfect Graphics) format.")
     (license (list mpl2.0 lgpl2.1+))))            ;dual licensed
 
+(define-public libcmis
+  (package
+    (name "libcmis")
+    (version "0.5.0")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://sourceforge/" name "/" name "-"
+                          version ".tar.gz"))
+      (sha256 (base32
+               "1dprvk4fibylv24l7gr49gfqbkfgmxynvgssvdcycgpf7n8h4zm8"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("cppunit" ,cppunit)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("boost" ,boost)
+       ("curl" ,curl)
+       ("cyrus-sasl" ,cyrus-sasl)
+       ("libxml2" ,libxml2)
+       ("openssl" ,openssl)))
+    (arguments
+     `(#:configure-flags
+        (list
+          ;; FIXME: Man pages generation requires docbook-to-man; reenable
+          ;; it once this is available.
+          "--without-man"
+          ;; avoid triggering configure errors by simple inclusion of
+          ;; boost headers
+          "--disable-werror"
+          ;; During configure, the boost headers are found, but linking
+          ;; fails without the following flag.
+          (string-append "--with-boost="
+                         (assoc-ref %build-inputs "boost")))))
+    (home-page "http://sourceforge.net/projects/libcmis/")
+    (synopsis "CMIS client library")
+    (description "LibCMIS is a C++ client library for the CMIS interface.  It
+allows C++ applications to connect to any ECM behaving as a CMIS server such
+as Alfresco or Nuxeo.")
+    (license (list mpl1.1 gpl2+ lgpl2.1+)))) ; triple license
+
 (define-public libabw
   (package
     (name "libabw")