summary refs log tree commit diff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorKaelyn <kaelyn.alexi@protonmail.com>2022-11-25 22:39:45 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-20 01:00:05 +0100
commit68925b5ee7e0d96b0c84ae98a633eea5097bf511 (patch)
treef2d687673e47a26f38e61c1473a3b5dd9b3fbb9a /gnu/packages/libreoffice.scm
parent536adbd7cca1f257261645d9cfd7910a0055a60e (diff)
downloadguix-68925b5ee7e0d96b0c84ae98a633eea5097bf511.tar.gz
gnu: libreoffice: Build reproducibly.
* gnu/packages/libreoffice.scm (libreoffice)[arguments]: Include ‘.otp’
files in the 'reset-zip-timestamps phase.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index da4cb8ad43..17127041d3 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1159,7 +1159,7 @@ converting QuarkXPress file format.  It supports versions 3.1 to 4.1.")
               (for-each (lambda (file)
                           (invoke "ziptime" file))
                         ;; So many different extensions for .zip files.
-                        (find-files #$output "\\.(bau|dat|otp|ott|zip)$"))))
+                        (find-files #$output "\\.(bau|dat|otg|otp|ott|zip)$"))))
           (add-after 'install 'bin-and-desktop-install
             ;; Create 'soffice' and 'libreoffice' symlinks to the executable
             ;; script.